Interface firewall is preventing images from displaying on open access webpage


#1

I’m on V10.1
My firewall settings are configured to allow all access for Webpages.

But my firewall settings for Interface are configured to block all except a white-list of our corporate IP Addresses.

The intention is, internal staff can use the interface and the general public can access a webpage. In terms of functionality this works fine.

What doesn’t work is the display header/footer option for the webpage. Specifically, the logo image is behind the Interface firewall and doesn’t display.

Is there a way to configure the firewalls such that images are accessible to all when the interface is blocked?


#2

Hi Craig

A good question, I’d like to run this past our technical team to make sure the answer I give adheres to best practice.

I’ll get back to you as soon as possible.

Thanks

Ian


#3

Hi Craig

I’ve checked with our Technical team and there are a couple of approaches depending on where your images are stored and how they’ve been defined.

Here is our initial take on the issue and our basic assumptions. If we are not correct, please let us know and we’ll take you through some other alternatives.

We are assuming that the images you are using have been defined in the traditional way within MATS as an Asset, as opposed to via a Variable.

We are assuming that the images are hosted as Assets within the Build environment, as opposed to, say, an external environment (Google, etc.)

Given the above, when defining an Image as an Asset, there is a Check-box within the Add Asset Image screen labelled ‘Is Public’. When this is checked, it allows the Image to be made available to an external facing page.

If you have already checked this box, or your environment is different from my assumptions, please let me know and we’ll explore the alternative routes.

Firewall%20Images


#4

Hi Ian,
Your assumptions are all correct, but yes, I have already checked the “Is Public” tick box.

If it helps, this is reproducible with the default theme.

Craig


#5

Hi Craig

If however the files are located on an external resource such as a cdn, aws or website, there is an additional firewall setting where you can define which other domains are permitted to contribute content.

Build -> Security - > Firewall & Access Profiles -> Interface / Webpage -> Browser Protection

Click “+Add New” under the “Domains that can contribute content to the MATS application

Under Domain be sure to add the full domain including http or https tags.

So for as long as you can access the image on your public domain via its webpath, you can add the domain here and tick images to allow it, despite your firewall rule.


#6

I think my earlier reply maybe wasn’t clear. The suggested solution doesn’t work for me.


#7

Hi Craig,

My name is Mark Pearson. I am one of the builders at Matssoft and I am here to help you resolve your issue if I possibly can.

Could I please ask if you could raise a support ticket in the usual way, supplying as much information about the issue as possible, including examples if possible. If I can replicate your issue it will help me enormously to get to the root of your issue.

I will keep an eye out for your ticket and ensure that it receives the swiftest attention.

Best Regards - MP


#8

Thanks, I’ve submitted a support ticket.
Craig


#9

Hi Craig,

Thanks for that. I have picked up the ticket and will look at it asap. Could you please do me a favour if you get a chance, and add a page url to the ticket which represents the screenshot you uploaded?

Many Thanks and have a great weekend

MP